Transform node's strange behavior


#1

Transform node doesn’t take in account the ‘Black Outside’ option to automatically extend color edges as it does in Nuke.
Is that normal ?


#2

Yes it does. However, if a second transform node follows the first, this parameter is ignored, and transforms are “concatenating”, so you should set it on the last transform node.
Is that the case?


#3

ok actually we would need the AdjustRoD to fill with non-black pixels, I’ll try to fix that befor the release.
Then you can do Source->AdjustRoD->Transform(with black outside unchecked) to fill all the black areas.
In Natron, every area outside of the bbox is black in transparent, whereas Nuke has a special flag to say it’s not.
I’ll change the AdjustRoD plugin to add the black outside flag


#4

ok, in 2.2 you just have to insert a AdustRoD node with the proper Border Conditions parameter.

In 2.1.9, just put a Crop node before your transform to enlarge the image.