Problem with premult and alpha when rendering image sequence (solved)


#1

Hello!

It’s been a while since i last used node based post processing so i’m sure i’m making a rookie mistake but i have a problem regarding the rendering of image sequences. in this case i want to have multiple sources displayed at the same time and then overlay a logo and then fade to the blue BG color. Everything looked fine in the viewer, but then i tried to render it out.

at first it didn’t work at all and then when i did an unpremult at the end i can render mp4s with the desired result. but when i try to render TIF or TGA image sequences the only “visible” source is the last one in the merge order.

Any suggestions on how to go about fixing it would be greatly appreciated. here is a screencap of the node network.

This is the result if i try to render a image sequence:

https://drive.google.com/file/d/0B2M8CKhTbeBHTW1wWjJRQWNBRmc/view?usp=sharing


#2

Hello,

Maybe a transparency issue coming from your PSD overlaid file. Try to save your overlay logo not as a psd file but as a png file ( this for keeping transparency ) . Then use this png file instead of your psd file in your compositing !


#3

Can you post a grab of the final render? My gut is saying that you need a pre-mult node for each of your sources that have an alpha built in, like the logo which is on top of everything


#4

thanks i will try to premult first to see if it works!

i can only post one image. but the drive link is to a final rendered image.


#5

nope same problem, what basically seems to happen is that somehow the only thing that gets rendered is read 6. but the background and logo works fine and they fade in as intended. it’s just that somehow only that part of the screen is rendered. i don’t know why since i have turned off all alphas in all merge nodes except for merge 4 &3.

and as i previously stated it renders fine to MP4. but when i try to render to image sequence it somehow doesn’t work.


#6

Insert a Shuffle with Alpha to 1 before your write node


#7

i will test that a little bit later! thanks for the reply!


#8

Works like a charm!

Thank you very much!