MultiView EXR avoiding auto creation of views


#1

I have multi view stereo exr files (left & right views within one file) written out of Blender 2.78c.

When adding a read node to the scene Natron prompts to make stereo views for you.
I say no, use shuffle nodes and comp as I want to… so far all good.

When I reopen the file it prompts again for each read node… annoying but ok, I just say no.
When I attempt to cmd line render Natron auto answers yes, which results in Natron crashing with the following.

"Persistent message: Could not find layer xxxxxx in view Right…"

So without further complicating this question about stereo workflow, formats, blender options, etc… I’ll ask.

How can I stop this option from being presented, or auto answered via cmd line?
I’ve been all over the prefs, and found nothing, and no similar requests here or through web search.

Thanks


#2

Hi,

This is indeed not the way it was thought, I will fix the dialog so it prompts you only once.
The workaround currently would just be to create the views anyway but always work on a single view.


#3

Thank you for the reply,
However this opens up the question further (which I was trying to avoid), because if the view simply exists in the scene, I will get the error.
Perhaps this is an issue with how Blender is writing the exr file metadata? Or perhaps I’m not setting up the “views” correctly in Natron (not that I can find any real controls for it)

This is the image info for my render (since I’m a new user the forum won’t let me attach a file directly)

Just adding it into the scene and switching to the “right” view, causes the error and all rendering fails due to a “missing layer” within the view. Even if I don’t switch from the default view, renders still fail out.

I see nothing on the read node to denote what channels go to what view, and shuffling into a “oneview” node does not bypass the error since it happens on the read node itself.
You can find tutorials of joining views from single view inputs (ie 2 separate images going into a “join views” node) but none with the views already embedded into a single exr.

My output from Blender is set as “OpenEXR MultiLayer” using the default cycles stereo camera, and default stereo views enabled in the render layers. I’d think these two apps should play well together.

Any ideas?


#4

Can you send me such a sample exr file ? I’ll try to fix it in a minor 2.2.x release


#5

So this is the blender output.
Composite.Combined.left and Composite.Combined.right layers are redundant (I don’t know how to remove them even with Composite and Sequencer options off in render settings)
But the cave.Combined.left & cave.Combined.right layers are created from the built in render pass & stereo camera (pano) options from within blender and saved with the MultiLayer EXR option.

https://dl.dropboxusercontent.com/u/7409130/caveSmoke_v008.0425.exr


#6

There was a bug in the Reader: it wouldn’t interpret the layer names correctly. I fixed it, it should be in the next snapshot and the next minor release.

I fixed in Natron also so that the question about the view creation only pops up once per file.


#7

Thanks for the quick fix.
All seems to be working well now.