Mocha Tracks In Natron?


#1

Is it possible to import tracking data from Mocha? I have a series of shots requiring rig removal coming up and haven’t found a good way to track in the plates with a lot of perspective shift. Just seeing what others recommend. Thanks!


#2

Krista,

Mocha data import is not available as of yet.


#3

If you know a bit of python I think you can export mocha data (at least corner pins) to human readable format and then parse it and convert it to a Natron corner pin… I haven’t mocha at hand but I’m pretty sure this is doable…


#4

Boris FX released Mocha as an OFX plugin recently. https://borisfx.com/pages/mocha-pro


#5

Nice, didn’t know that Boris had taken over Mocha. Anyone tried Mocha OpenFX in Natron?

Have an old version of Mocha Pro, but haven’t used it in a while.


#6

maybe this script can be converted to use it with natron
http://richardfrazer.com/tools-tutorials/import-mocha-ae-tracks-to-nuke-via-python/
cheers


#7

I tested Mocha Pro Plugin for OFX on Ubuntu. It’s not working:

install

Installed it by converting the package from rpm to deb using Alien:

sudo apt-get install alien
sudo alien mochaProOFX-5.1.0-12413-f556403.rhel.rpm
sudo dpkg -i mochaproofx_5-1_amd64.deb

that seems OK and it turned up in natron.

test 1

added a tiff sequence and piped to mocha node then viewer. The processor maxed out for about 30 secs then Natron crashed with:

Info: init.py script not loaded (this is not an error)
Info: initGui.py script not loaded (this is not an error)
/root/natron-support/buildmaster/tmp/oiio-Release-1.6.16/src/libtexture/imagecache.cpp:3163: failed assertion ‘errptr->size() < 1024102416 && “Accumulated error messages > 16MB. Try checking return codes!”’
Fontconfig error: Cannot load default config file

test 2

new nodegraph added a colorwheel, then mochapro node, then viewer. This crashed natron:

Info: init.py script not loaded (this is not an error)
Info: initGui.py script not loaded (this is not an error)
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method
./Natron: relocation error: /usr/lib/x86_64-linux-gnu/libssl.so: symbol OPENSSL_init_library, version OPENSSL_1.0.2g not defined in file libcrypto.so.1.0.0 with link time reference

I wonder if it has to do with license registration? It’s unregistered: license tool says:

The license database cannot be read. Directory ‘/etc/opt/bis/licenses’ does not exist

I logged a case with Boris FX Support ref:_00D2083I._500D01FcioR:ref

test on osx

  1. install OK
  2. added read & mocha to node graph OK
  3. clicked License Control OK
  4. clicked Launch mocha UI OK
  5. set in and out points
  6. added bezier mask
  7. tracked
  8. close and save
  9. clicked View Matte . OK! :smile:

So Mocha Pro is working on OSX but not Linux.


#8

It’s probably a conflict with the dependencies. Can you output the Mocha dependencies?

ldd mocha_plugin_binary


#9

So, I downloaded the trial…

libmochapro4avx.so requires a lot of dependencies, but they are built into the library. On CentOS7 I get undefined symbol: gluOrtho2D from libmocha. May work on the distros they support (RHEL4/RHEL5), I don’t know. Anyway, not a Natron issue.


#10

Works in Nuke7 on CentOS7.


#11

Ok, so got it working. We need to link directly to GLU in Natron (on Linux) to satisfy Mocha.


#12

Hey really great. It’s just awesome that we can have Mocha in Natron.


#13

I didn’t do much testing, but the gui window launched and seems to work as it should.

They (Mocha) should still fix their binary (but will probably not happen since they only support Nuke/Fusion), it should link against everything it needs, not assume that the host does it for them :slightly_smiling:


#14

I’ll test a little more on OSX first.


#15

Thank you, I will check this out!


#16

Just bought the OFX plugin for this today. UI and tracking works great, but what export format should I use that will work with Natron?


#17

hi @ElDirector when is that, do you mean when you go to close the Mocha window to return to the node graph?


#18

Sort of. Just running a track in Mocha doesn’t do anything to the node graph. In Fusion, Nuke and AE, you can export your track data selecting the appropriate app and copy to the clipboard. Then you hit CTRL V in the nodegraph and a transform or corner pin appears to hold and use the tracking data, much like when we export tracking data using Natron’s tracker.


#19

Has anyone made any progress and/or can offer any further advice on how to get Mocha tracking data into Natron? As ElDirector said, there’s no simple way to export the track data from Mocha to Natron since there’s no Natron option in the Export Track dialog. However, since Natron seems so similar to other compositing apps and track data can be broken down simply, is there a way to import something like Nuke ASCII (.txt) track data into Natron?

I tried to modify the python script from the link sembel suggested (link) but it’s not my area of expertise. I keep getting a python error on execution. It would seem feasible to modify that script for Natron’s purpose, though, right? If anyone else has figured out something better or can shed some light onto this matter, please let me know. Thanks


#20

This is possible but one has to write the Python wrapper using Natron Python API.