Issue with retime and it's curve?


#1

Hi,
I’ve tried to use the retime node with the curve editor, but can’t get the expected result.

I have 3 key points in a row. The first and third key point is at 1 - the video should play in normal speed before and after these key points.
The middle key point has any value > 1. All key points are on smooth interpolation, so I expect the video to slowly increase and decrease it’s speed after/before the middle key point.
http://i.imgur.com/hDrPU81.png

But the result is not the one I’ve expected. I get the same result as when I set the first and second key point to constant interpolation. From the first to the second key point the speed stays at 1 and at the second key the speed is instant at the maximal value and is constant high to the third key point, where the speed returns instant to 1 again. However, the value of the current speed in the retime properties seems to correctly interpolate.
http://i.imgur.com/7dEjI3R.png

This looks a bit like this, but there’s no crash and the issue is marked as fixed.
I’ve tried this with Natron 2.1.9.
I hope this works, here is a minimal example: http://www.xup.in/dl,54744935/retime-bug.ntp/

Is this known or the expected behavior? Doesn’t retime work with anything other than constant interpolation?

Lucki

PS.: What’s this for shit: “Sorry, new users can only put one image in a post.” :rage:
PPS.: And this: “Sorry, new users can only put 2 links in a post.”
PPPS.: And this: “Sorry, new users can not upload attachments.” How should I fill my post with useful information?


#2

Is this a bug which can be fixed?
Or am I doing something wrong?


#3

Bugs are best reported at https://github.com/MrKepzie/Natron/issues

I will look into it


#4

Yesterday I’ve updated to Natron 2.2.0, but this still happens.


#5

(Finally) Fixed by https://github.com/MrKepzie/Natron/commit/cee3e103aee134efe036b9397c01ee3682c89ee5

P.S.: I can’t edit my first’s title post to [solved]