I can no longer set keys on position/size of Draw objects such as Radial


#1

I have no idea what changed this behavior, and I can still set keys for other attributes such as Mix and Softness, but when I right click to set a key on position or size, all I get is Copy, Reset to Default, and Set Expression. The same even happens for previous project files where I have animated masks, but the option no longer appears despite animation going along as previously authored.

I’m really at a loss, I just need to move some masks around and it seems like I can’t set any keyframes anymore. I suppose it could simply be that I’m a bit of a noob with this particular compositing software, but I was able to keyframe these attributes quite recently. I suppose I could just use a transform node, but that would clutter my node layout and I still wouldn’t be able to adjust previous projects.

Any help with this matter would be greatly appreciated. Thank you for reading.

UPDATE: I still haven’t found anything regarding this issue. Now I’m just wondering if there are no replies because I missed something obvious, or because no one else is experiencing this issue.


#2

Hello,

Hum, there is (sadly) not that much people answering on this forum, this is why you don’t get any answers…
I haven’t tested it before but keying the radial position indeed doesn’t work on my 2.2.7 version too . I’ve tested the Ramp node and it works.

Maybe this is intended behavior because the Radial coordinate looks more like a bounding box and it’s a bit different than Ramp’s coordinates.

You can still put a Transform node after the Radial , this is not so uncommon to stack operations and use several nodes to get what you want.

To recover your old project, you may have to install an old version that works, or redo the animation , I don’t know what’s the less painful for you.

Try to fill a bug report in the natron forums in case this not intended…

At least you’ll know if it’s going to change in a future version or if this behavior is going to stay …

Good luck :slight_smile:


#3

Thank you for taking the time to respond. Well, my old projects still work and look identical, which is what’s confusing. Although I can’t set keys on new draw objects, and the existing objects don’t show any transformations on the curve editor or the dope sheet, they’re still there somehow. So, theoretically, it should still be possible to do.

Still, I think I buy the logic of this not being an intended behavior, although I must admit altering a bounding box is ten times easier than managing double the objects and using the finicky transform gizmo. It’s just that now I’ll have to keep track of so much, but I think I can at least make it easier to digest by hiding the unchanging attributes from the options panel (whatever it’s called on the right). Using an older version would be more annoying, especially since I keep updating the dependencies here on Linux.

Yeah, I think I’ll dig for an existing bug before making a new one so I can at least know how I’m supposed to do this kind of thing. I think I’ll also argue the point that it should remain since it’s more intuitive and efficient, in my mind. Thanks again for your willingness to speak up.


#4

Yeah it’s nice to be able to key everything even if it’s not intended…
It can be a bug or the dev’s have disable it on purpose, the bug report will tell …

In your case it can become a bit of a mess, because you’ve got moving things in the radial that only show up in the viewport, and a transform node to counter animate this, it must be tedious.
Starting from the beginning with a static radial and doing transform with the transform node will be less painful.

If you’re really geeky and have a lot of these setup to do you can make a custom nodegroup with only the parameters that you need only for that purpose , but maybe that’s too much…


#5

This seems likely to be a bug. Keying the radial transforms can’t be replaced by keying a transform after the radial node, since the radial is rasterized before the transform node can be applied.

It’d be nice if the transforms concatenated, though, but perhaps not worth the effort.


#6

This is a bug that was introduced in a recent version: all generators now have the capability to set the Output Format (the plain rectangle seen in the viewer). Problem is, the format is not frame variant, hence we cannot have parameters that set the format vary over time. We need to fix that so that the parameter can vary over time only if Reformat is unchecked.


#7

I see, thank you for the update! I was hoping to report the bug sometime today, and I’m still having trouble finding it in the Github issues. Is there one already present, or should I go ahead and make a new issue for this?

Of course, I’m happy to uncheck reformat on any such generator, so that sounds like an ideal fix to me. Would I be right to assume my only recourse for now is to use transform nodes? Apologies if my wording is somewhat off- I’m still adapting to this wonderful program’s idiosyncrasies.


#8

MrKepzie will tell if I’m wrong, but as long as he is aware of the bug I think you don’t need to make a bug report.

You must stick to transform nodes until it’s fixed, you can also check development snapshots from time to time, if you don’t want to wait until the next release . It seems that a new version of Natron is released every 2/3 month now.
That said, snapshots are good for testing but it’s a bit risky to do serious work with it.


#9

This was fixed a few days ago, please check out the snapshots


#10

I’ll check it out soon and get back to you guys with an edit.