Shadertoy plugins give error on NVIDIA GPUs


When I try to use Shadertoy-based plugins, I get the following error (In this case with PM_Vectorblur):

PM_VectorBlur: Can not render: OpenGL 2.0 or GL_ARB_texture_non_power_of_two is required.

On my Linux workstation, the plugins work fine in the GUI, but rendering out fails with the above error. On a Windows PC I tested, also with NVIDIA GPU, I got the same error also in the GUI.

I tried disabling GPU rendering for the relevant shadertoy nodes in the plugin, but then my render ended with a segfault instead.

Any ideas appreciated!


@hulmanen I’m having the exact same issue with the Shadertoy node (Win10-64b, Natron 2.3.7, Nvidea GTX 1050 ti).
Can’t render my project wich uses Shadertoy shaders. Crazy since the graphics card is having more then requirements.
Your post is from a year ago so I wonder; have you found a solution to this problem?


I have the same problem on Windows, almost never on the Linux version.
It mainly happens when the viewer zoom is set to a non power of two value, like 33 or 75%.
This may be an explaination.


Alright, thanks @fabiof17 for your quick reply. I’ll take a closer look at the zoom-factor of the viewer and will continue to search for ways to avoid this error. Although I believe here it also happens when there is no viewer node on the nodegraph.

After last days of working in Natron I’m really impressed. This is a great program with a lot of possibilities and as a regular After Effects user I think it’s really competing and at some points even better and more fun to work with. But this issue rises so many times now on different types of nodes here that a lot of node-types throw this error and so can’t be used in a project. This makes the software feel unstable and that’s a pitty for such a great program.

I will continue searching for ways to avoid the error, but at the monent I can’t find anything I do wrong and my system got more then the requirements, so it seems to be something inside the software I’m missing here or there is perhaps an issue in the software.

So I hope anybody on this forum could help me with some clue on when this problem occurs and knows a solution for it.


You should try the latest version 2.3.8, if not already done. It has been reported to solve some issues with the viewer.


@fabiof17 Thanks, I updated Natron this week, but seems like there is already a new version out! Great! I’ll try that to find out this issue is fixed. Thans again for your tip and have a great weekend.


@hulmanen and @Friblios it helps a lot if you give the infos obtained by clicking “Renderer info…” in Shaderoy when reporing this kind of problem. Also, is the problem solved when you unselect “Enable GPU Render”?